Thread (17 messages) flat view 17 messages, 3 authors, 2021-10-04

Re: [PATCH v5 1/3] staging: vt6655: fix camelcase in bShortSlotTime

From: Tommaso Merciai <tomm.merciai@gmail.com>
Date: 2021-10-04 17:30:14
Also in: lkml

On Mon, Oct 04, 2021 at 04:15:25PM +0300, Dan Carpenter wrote:
On Mon, Oct 04, 2021 at 02:58:06PM +0200, Tommaso Merciai wrote:
quoted
On Mon, Oct 04, 2021 at 01:26:32PM +0300, Dan Carpenter wrote:
quoted
On Thu, Sep 30, 2021 at 11:49:29PM +0200, Tommaso Merciai wrote:
quoted
On Tue, Sep 28, 2021 at 06:43:00AM +0200, Greg Kroah-Hartman wrote:
quoted
On Mon, Sep 27, 2021 at 11:35:15PM +0200, Tommaso Merciai wrote:
quoted
On Mon, Sep 27, 2021 at 05:26:14PM +0200, Greg Kroah-Hartman wrote:
quoted
On Sun, Sep 26, 2021 at 06:25:18PM +0200, Tommaso Merciai wrote:
quoted
Replace camel case variable bShortSlotTime with snake case
variable b_short_slot_time.
That is a very odd variable name.  Why did you pick that one?

What deos it mean?

You do understand where the original naming format came from here, and
what it was trying to represent, right?  If not, please go read up on
it:
	https://en.wikipedia.org/wiki/Hungarian_notation

That style is not used in Linux, and so, when converting from it, do not
attempt to keep the same style present here, that is kind of pointless,
don't you agree?
  You are definitely right. What do you think about "short_slot_time"?
"time" implies that this will hold a value of time, right?

What exactly does this variable do?  That might help in naming it
better.
  Is a boolean variable, if true short slot time mode is enabled, false 
  not right?
  A good solution could be: "short_slot_mode"? What do you think about?
No.  That's a confusing name.  What is a short slot mode anyway?

regards,
dan carpenter
  Hi Dan,
  My bad sorry, "short_slot_time_en".
Ah, never mind.  It means something for the protocol.  I thought it was
driver specific.  Just use short_slot_mode like you original suggested.
The "_en" doesn't add anything.

In the commit message you out include the information from here so that
reviewers who don't know the wifi spec will understand the meaning.
  Thanks for the tip.

  Tommaso
regards,
dan carpenter
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help