Thread (17 messages) 17 messages, 3 authors, 2021-10-04

Re: [PATCH v5 1/3] staging: vt6655: fix camelcase in bShortSlotTime

From: Tommaso Merciai <tomm.merciai@gmail.com>
Date: 2021-09-30 21:49:36
Also in: lkml

On Tue, Sep 28, 2021 at 06:43:00AM +0200, Greg Kroah-Hartman wrote:
On Mon, Sep 27, 2021 at 11:35:15PM +0200, Tommaso Merciai wrote:
quoted
On Mon, Sep 27, 2021 at 05:26:14PM +0200, Greg Kroah-Hartman wrote:
quoted
On Sun, Sep 26, 2021 at 06:25:18PM +0200, Tommaso Merciai wrote:
quoted
Replace camel case variable bShortSlotTime with snake case
variable b_short_slot_time.
That is a very odd variable name.  Why did you pick that one?

What deos it mean?

You do understand where the original naming format came from here, and
what it was trying to represent, right?  If not, please go read up on
it:
	https://en.wikipedia.org/wiki/Hungarian_notation

That style is not used in Linux, and so, when converting from it, do not
attempt to keep the same style present here, that is kind of pointless,
don't you agree?
  You are definitely right. What do you think about "short_slot_time"?
"time" implies that this will hold a value of time, right?

What exactly does this variable do?  That might help in naming it
better.
  Is a boolean variable, if true short slot time mode is enabled, false 
  not right?
  A good solution could be: "short_slot_mode"? What do you think about?

  thanks,
  tommaso
thanks,

greg k-h
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help