Quoting Richard Guy Briggs (rgb at redhat.com):
On 2017-08-25 15:58, James Morris wrote:
quoted
On Wed, 23 Aug 2017, Richard Guy Briggs wrote:
quoted
Introduce inline root_privileged() to make use of SECURE_NONROOT
easier to read.
Suggested-by: Serge Hallyn <serge@hallyn.com>
Signed-off-by: Richard Guy Briggs <redacted>
---
security/commoncap.c | 9 +++++----
1 files changed, 5 insertions(+), 4 deletions(-)
Acked-by: James Morris <redacted>
Does anyone have the appetite to move this helper function to
include/linux/securebits.h along with issecure() to make it more widely
available?
If it's going to have wider scope, then it probably needs to be
renamed to be unambiguous in any context. root_implies_privilege
or uid0_is_privileged maybe? Maybe root_privileged() is ok...
--
To unsubscribe from this list: send the line "unsubscribe linux-security-module" in
the body of a message to majordomo at vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html