[PATCH v3 02/15] exec: Rename bprm->cred_prepared to called_set_creds
From: jmorris@namei.org (James Morris)
Date: 2017-07-19 09:20:08
Also in:
linux-fsdevel, lkml
From: jmorris@namei.org (James Morris)
Date: 2017-07-19 09:20:08
Also in:
linux-fsdevel, lkml
On Tue, 18 Jul 2017, Kees Cook wrote:
The cred_prepared bprm flag has a misleading name. It has nothing to do with the bprm_prepare_cred hook, and actually tracks if bprm_set_creds has been called. Rename this flag and improve its comment. Cc: David Howells <dhowells@redhat.com> Cc: John Johansen <john.johansen@canonical.com> Cc: Paul Moore <paul@paul-moore.com> Cc: Stephen Smalley <redacted> Cc: Casey Schaufler <casey@schaufler-ca.com> Cc: James Morris <redacted> Signed-off-by: Kees Cook <redacted>
Acked-by: James Morris <redacted> -- James Morris [off-list ref] -- To unsubscribe from this list: send the line "unsubscribe linux-security-module" in the body of a message to majordomo at vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html