Thread (8 messages) 8 messages, 3 authors, 2021-06-25

Re: [PATCH v2 1/3] ufs: Reduce code duplication in the runtime power managment implementation

From: Bean Huo <hidden>
Date: 2021-06-25 12:36:33

On Thu, 2021-06-24 at 16:29 -0700, Bart Van Assche wrote:
 static const struct dev_pm_ops tc_dwc_g210_pci_pm_ops = {

-       .suspend        = tc_dwc_g210_pci_suspend,

-       .resume         = tc_dwc_g210_pci_resume,

-       .runtime_suspend = tc_dwc_g210_pci_runtime_suspend,

-       .runtime_resume  = tc_dwc_g210_pci_runtime_resume,

-       .runtime_idle    = tc_dwc_g210_pci_runtime_idle,

+       .suspend         = ufshcd_system_suspend,

+       .resume          = ufshcd_system_resume,

+       .runtime_suspend = ufshcd_runtime_suspend,

+       .runtime_resume  = ufshcd_runtime_resume,

        .prepare         = ufshcd_suspend_prepare,

        .complete        = ufshcd_resume_complete,
Hi Bart,
you need to update this patch since you forgot to change the vendor's
driver.


drivers/scsi/ufs/cdns-pltfrm.c
drivers/scsi/ufs/tc-dwc-g210-pltfrm.c
drivers/scsi/ufs/ufs-exynos.c
drivers/scsi/ufs/ufs-hisi.c
drivers/scsi/ufs/ufs-mediatek.c
drivers/scsi/ufs/ufs-qcom.c


Bean
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help