Re: [PATCH v4 02/10] scsi: ufs: Add flags pm_op_in_progress and is_sys_suspended
From: Can Guo <hidden>
Date: 2021-06-24 02:07:58
Also in:
lkml
On 2021-06-24 04:59, Bart Van Assche wrote:
On 6/23/21 12:35 AM, Can Guo wrote:quoted
diff --git a/drivers/scsi/ufs/ufshcd.h b/drivers/scsi/ufs/ufshcd.h index 93aeeb3..1e7fe73 100644 --- a/drivers/scsi/ufs/ufshcd.h +++ b/drivers/scsi/ufs/ufshcd.h@@ -754,6 +754,8 @@ struct ufs_hba { struct device_attribute spm_lvl_attr; /* A flag to tell whether __ufshcd_wl_suspend/resume() is inprogress */ bool wlu_pm_op_in_progress; + /* A flag to tell whether ufshcd_suspend/resume() is in progress */ + bool pm_op_in_progress; /* Auto-Hibernate Idle Timer register value */ u32 ahit;@@ -841,6 +843,8 @@ struct ufs_hba { struct ufs_clk_scaling clk_scaling; /* A flag to tell whether the UFS device W-LU is system suspended */ bool is_wlu_sys_suspended; + /* A flag to tell whether hba is system suspended */ + bool is_sys_suspended; enum bkops_status urgent_bkops_lvl; bool is_urgent_bkops_lvl_checked;It is not yet clear to me whether we really need these new member variables. If these are retained, please rename pm_op_in_progress into platform_pm_op_in_progress and is_sys_suspended into platform_is_sys_suspended.
Hi Bart, These flags are informative when we debug some UFS issues and they are used by later changes. Sure, I will modify the namings. Thanks, Can Guo.
Thanks, Bart.