Thread (14 messages) 14 messages, 5 authors, 2021-12-16

Re: [PATCH 1/3] vmcore: Convert copy_oldmem_page() to take an iov_iter

From: Heiko Carstens <hca@linux.ibm.com>
Date: 2021-12-16 09:29:08
Also in: kexec, linux-fsdevel, lkml

On Mon, Dec 13, 2021 at 08:57:25AM +0100, Christoph Hellwig wrote:
On Mon, Dec 13, 2021 at 12:06:34AM +0000, Matthew Wilcox (Oracle) wrote:
quoted
Instead of passing in a 'buf' and 'userbuf' argument, pass in an iov_iter.
s390 needs more work to pass the iov_iter down further, or refactor,
but I'd be more comfortable if someone who can test on s390 did that work.

It's more convenient to convert the whole of read_from_oldmem() to
take an iov_iter at the same time, so rename it to read_from_oldmem_iter()
and add a temporary read_from_oldmem() wrapper that creates an iov_iter.
This looks pretty reasonable.  s390 could use some love from people that
know the code, and yes, the kerneldoc comments should go away.
Sure, we will take care of this. Added to ToDo list.
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help