RE: [PATCH RFC 2/2] RDMA/nldev: provide detailed CM_ID information
From: Parav Pandit <hidden>
Date: 2018-01-31 21:18:39
-----Original Message----- From: linux-rdma-owner-u79uwXL29TY76Z2rM5mHXA@public.gmane.org [mailto:linux-rdma- owner-u79uwXL29TY76Z2rM5mHXA@public.gmane.org] On Behalf Of Steve Wise Sent: Wednesday, January 31, 2018 2:56 PM To: Parav Pandit <parav-VPRAkNaXOzVWk0Htik3J/w@public.gmane.org>; dledford-H+wXaHxf7aLQT0dZR+AlfA@public.gmane.org; Jason Gunthorpe [off-list ref] Cc: linux-rdma-u79uwXL29TY76Z2rM5mHXA@public.gmane.org; leon-DgEjT+Ai2ygdnm+yROfE0A@public.gmane.org Subject: RE: [PATCH RFC 2/2] RDMA/nldev: provide detailed CM_ID informationquoted
quoted
182,6 +199,7 @@ static int fill_res_info(struct sk_buff *msg, structib_devicequoted
quoted
*device) [RDMA_RESTRACK_PD] = "pd", [RDMA_RESTRACK_CQ] = "cq", [RDMA_RESTRACK_QP] = "qp", + [RDMA_RESTRACK_CM_ID] = "cm_id",May be rdmacm_id a better name to avoid confusion with ib_cm/iw_cm ids?Eventually, I could see the ib_cm and/or iw_cm info also getting dumped as part
Yes. But it is still coming through id of rdmacm_id as transport id information.
of this. So perhaps the name "cm_id" is ok?
It's just that longer name removes the ambiguity. I am not too particular about this particular naming.
I prefer it also because its shorter (lazy typer! :) )
Sure, shorter names are useful to end user. But I think this is handled well at iproute2 tool level. For example below two commands achieves the same task. #ip address show #ip a s So may be shorter naming at command level is better left at user space tool level. -- To unsubscribe from this list: send the line "unsubscribe linux-rdma" in the body of a message to majordomo-u79uwXL29TY76Z2rM5mHXA@public.gmane.org More majordomo info at http://vger.kernel.org/majordomo-info.html