Thread (63 messages) 63 messages, 11 authors, 2021-10-18

Re: [PATCH 02/30] block: add a bdev_nr_bytes helper

From: Kees Cook <hidden>
Date: 2021-10-15 15:49:38
Also in: dm-devel, linux-bcache, linux-block, linux-btrfs, linux-ext4, linux-fsdevel, linux-nfs, linux-nvme, linux-scsi, ntfs3, target-devel

On Fri, Oct 15, 2021 at 02:37:41PM +0000, Anton Altaparmakov wrote:
Hi Christoph,
quoted
On 15 Oct 2021, at 14:26, Christoph Hellwig [off-list ref] wrote:

Add a helpe to query the size of a block device in bytes.  This
will be used to remove open coded access to ->bd_inode.
Matthew already pointed out the return type for bdev_nr_bytes() but also your commit message has a typo: "Add a helpe" -> "Add a helper".
Right. With these fixed, I'm a fan. :)

Reviewed-by: Kees Cook <redacted>

-Kees

-- 
Kees Cook
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help