Thread (109 messages) 109 messages, 19 authors, 2011-01-14

Re: [PATCH 08/11] block: rename barrier/ordered to flush

From: Tejun Heo <tj@kernel.org>
Date: 2010-08-17 16:23:55
Also in: dm-devel, linux-fsdevel, linux-ide, linux-scsi, lkml

Hello,

On 08/17/2010 03:26 PM, Christoph Hellwig wrote:
quoted
-#define blk_queue_flushing(q)	((q)->ordseq)
+#define blk_queue_flushing(q)	((q)->flush_seq)
Btw, I think this one should just go away.  It's only used by
ide in an attempt to make ordered sequences atomic, which isn't
needed for the new design.
Yeap, agreed.  I couldn't really understand why the the sequence
needed to be atomic for ide in the first place so just left it alone.
Do you understand why it tried to be atomic?

Thanks.

-- 
tejun
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help