On 12:20, Dan Williams wrote:
Move the raid6 data processing routines into a standalone module
(raid6_pq) to prepare them to be called from async_tx wrappers and other
non-md drivers/modules. This precludes a circular dependency of raid456
needing the async modules for data processing while those modules in
turn depend on raid456 for the base level synchronous raid6 routines.
To support this move:
1/ The exportable definitions in raid6.h move to include/linux/raid/pq.h
As raid*.h and md.h have been moved to drivers/md recently, pq.h
should probably live there as well.
+#define time_before(x, y) ((x) < (y))
This macro seems to have no users (and a strange name).
Regards
Andre
--
The only person who always got his work done by Friday was Robinson Crusoe