Re: [RFC PATCH v3] workqueue: Introduce show_one_worker_pool and show_one_workqueue.
From: Imran Khan <hidden>
Date: 2021-10-20 08:27:23
Also in:
lkml
Hi Tejun, On 20/10/21 5:41 am, Tejun Heo wrote:
On Sat, Oct 16, 2021 at 11:20:07AM +1100, Imran Khan wrote:quoted
Currently show_workqueue_state shows the state of all workqueues and of all worker pools. In certain cases we may need to dump state of only a specific workqueue or worker pool. For example in destroy_workqueue we only need to show state of the workqueue which is getting destroyed. So rename show_workqueue_state to show_all_workqueues(to signify it dumps state of all busy workqueues) and divide it into more granular functions (show_one_workqueue and show_one_worker_pool), that would show states of individual workqueues and worker pools and can be used in cases such as the one mentioned above. Also, as mentioned earlier, make destroy_workqueue dump data pertaining to only the workqueue that is being destroyed and make user(s) of earlier interface(show_workqueue_state), use new interface (show_all_workqueues). Signed-off-by: Imran Khan <redacted>Can you respin the patch on top of the following branch? git://git.kernel.org/pub/scm/linux/kernel/git/tj/wq.git for-5.16
Sure, I have rebased it upon the suggested branch and have sent v4 [1] of the change. [1] https://lore.kernel.org/lkml/20211020030900.321837-1-imran.f.khan@oracle.com/ (local) Thanks, --Imran
Thank you.