Thread (3 messages) 3 messages, 2 authors, 2021-10-20

Re: [RFC PATCH v3] workqueue: Introduce show_one_worker_pool and show_one_workqueue.

From: Tejun Heo <tj@kernel.org>
Date: 2021-10-19 18:41:44
Also in: lkml

On Sat, Oct 16, 2021 at 11:20:07AM +1100, Imran Khan wrote:
Currently show_workqueue_state shows the state of all workqueues and of
all worker pools. In certain cases we may need to dump state of only a
specific workqueue or worker pool. For example in destroy_workqueue we
only need to show state of the workqueue which is getting destroyed.

So rename show_workqueue_state to show_all_workqueues(to signify it
dumps state of all busy workqueues) and divide it into more granular
functions (show_one_workqueue and show_one_worker_pool), that would show
states of individual workqueues and worker pools and can be used in
cases such as the one mentioned above.

Also, as mentioned earlier, make destroy_workqueue dump data pertaining
to only the workqueue that is being destroyed and make user(s) of
earlier interface(show_workqueue_state), use new interface
(show_all_workqueues).

Signed-off-by: Imran Khan <redacted>
Can you respin the patch on top of the following branch?

 git://git.kernel.org/pub/scm/linux/kernel/git/tj/wq.git for-5.16

Thank you.

-- 
tejun
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help