Re: [PATCH v6 09/14] NFSD: Clean up nfsd4_init_file()
From: Chuck Lever III <hidden>
Date: 2022-10-27 23:47:09
From: Chuck Lever III <hidden>
Date: 2022-10-27 23:47:09
On Oct 27, 2022, at 7:22 PM, NeilBrown [off-list ref] wrote: On Fri, 28 Oct 2022, Chuck Lever wrote:quoted
Name nfs4_file-related helpers consistently. There are already nfs4_file_yada functions, so let's go with the same convention used by put_nfs4_file(): init_nfs4_file().I don't understand. You say "consistently", then you say that as we have lots of "nfs4_file_yada" functions, this new one will NOT follow that pattern.
Patch description is admittedly terse. I want a naming convention that sets apart the helpers that deal with the nfs4_file hash table. Maybe nfs4_file_hash_yada would be a better choice? But we already have put_nfs4_file()...
Surely "consistency" means renaming put_nfs4_file() to nfs4_file_put(), and introducing nfs4_file_init(). Not that I really care that much about the naming, but would like to be able to follow your logic. Thanks, NeilBrown
-- Chuck Lever