On Fri, 28 Oct 2022, Chuck Lever wrote:
Name nfs4_file-related helpers consistently. There are already
nfs4_file_yada functions, so let's go with the same convention used
by put_nfs4_file(): init_nfs4_file().
I don't understand. You say "consistently", then you say that as we
have lots of "nfs4_file_yada" functions, this new one will NOT follow
that pattern.
Surely "consistency" means renaming put_nfs4_file() to nfs4_file_put(),
and introducing nfs4_file_init().
Not that I really care that much about the naming, but would like to be
able to follow your logic.
Thanks,
NeilBrown