Thread (8 messages) flat view 8 messages, 4 authors, 2012-09-13

Re: linux-next: build failure after merge of the akpm tree

From: Stephen Rothwell <hidden>
Date: 2012-09-13 08:31:14
Also in: lkml

Hi Andrew,

On Thu, 13 Sep 2012 00:56:57 -0700 Andrew Morton [off-list ref] wrote:
On Thu, 13 Sep 2012 17:44:41 +1000 Stephen Rothwell [off-list ref] wrote:
quoted
After merging the akpm tree, today's linux-next build (x86_64
allmodconfig) failed like this:

drivers/thermal/cpu_cooling.c: In function 'get_idr':
drivers/thermal/cpu_cooling.c:89:14: error: 'MAX_ID_MASK' undeclared (first use in this function)

Caused by commit "idr: rename MAX_LEVEL to MAX_IDR_LEVEL" from the akpm
tree interacting with commit 78edc7cdcf5e ("thermal: add generic cpufreq
cooling implementation") from the thermal tree.

I have applied the following merge fix patch and can carry it as
necessary.

...
--- a/drivers/thermal/cpu_cooling.c
+++ b/drivers/thermal/cpu_cooling.c
@@ -9,7 +9,7 @@
  *  it under the terms of the GNU General Public License as published by
  *  the Free Software Foundation; version 2 of the License.
  *
- *  This program is distributed in the hope that it will be useful, but
+ *  This program is distributed in the hope that it will be useful, butX_ID_MASK
  *  WITHOUT ANY WARRANTY; without even the implied warranty of
  *  MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
  *  General Public License for more details.
@@ -86,7 +86,7 @@ again:
 	else if (unlikely(err))
 		return err;
 
-	*id = *id & MAX_ID_MASK;
+	*id = *id & MAX_IDR_MASK;
 	return 0;
 }
Confused. 
http://ozlabs.org/~akpm/mmotm/broken-out/idr-rename-max_level-to-max_idr_level-fix-3.patch
already does this.  How did that change get into the wrong place?
So, ignore the first hunk above, that was my typo.  

Here is the chunk of the series file I have:

idr-rename-max_level-to-max_idr_level.patch
idr-rename-max_level-to-max_idr_level-fix.patch
idr-rename-max_level-to-max_idr_level-fix-fix-2.patch
#NEXT_PATCHES_END
#
linux-next.patch
i-need-old-gcc.patch
idr-rename-max_level-to-max_idr_level-fix-3.patch
arch-alpha-kernel-systblss-remove-debug-check.patch
#
#NEXT_PATCHES_START linux-next-urgent

So idr-rename-max_level-to-max_idr_level-fix-3.patch is excluded form
linux-next :-( I guess I need to just move that further down in the
series file?  Though when you send the preceding three patches to Linus,
that fix-3 patch will be needed when I merge the thermal tree.
-- 
Cheers,
Stephen Rothwell                    sfr@canb.auug.org.au

Attachments

Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help