From: Stephen Rothwell <hidden> Date: 2012-09-13 07:44:45
Hi Andrew,
After merging the akpm tree, today's linux-next build (x86_64
allmodconfig) failed like this:
drivers/thermal/cpu_cooling.c: In function 'get_idr':
drivers/thermal/cpu_cooling.c:89:14: error: 'MAX_ID_MASK' undeclared (first use in this function)
Caused by commit "idr: rename MAX_LEVEL to MAX_IDR_LEVEL" from the akpm
tree interacting with commit 78edc7cdcf5e ("thermal: add generic cpufreq
cooling implementation") from the thermal tree.
I have applied the following merge fix patch and can carry it as
necessary.
From: Stephen Rothwell <redacted>
Date: Thu, 13 Sep 2012 17:42:11 +1000
Subject: [PATCH] thermal: fix up for MAX_ID_MASK rename
Signed-off-by: Stephen Rothwell <redacted>
---
drivers/thermal/cpu_cooling.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
On 13 September 2012 13:14, Stephen Rothwell [off-list ref] wrote:
quoted hunk
Hi Andrew,
After merging the akpm tree, today's linux-next build (x86_64
allmodconfig) failed like this:
drivers/thermal/cpu_cooling.c: In function 'get_idr':
drivers/thermal/cpu_cooling.c:89:14: error: 'MAX_ID_MASK' undeclared (first use in this function)
Caused by commit "idr: rename MAX_LEVEL to MAX_IDR_LEVEL" from the akpm
tree interacting with commit 78edc7cdcf5e ("thermal: add generic cpufreq
cooling implementation") from the thermal tree.
I have applied the following merge fix patch and can carry it as
necessary.
From: Stephen Rothwell <redacted>
Date: Thu, 13 Sep 2012 17:42:11 +1000
Subject: [PATCH] thermal: fix up for MAX_ID_MASK rename
Signed-off-by: Stephen Rothwell <redacted>
---
drivers/thermal/cpu_cooling.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
* WITHOUT ANY WARRANTY; without even the implied warranty of
* MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
* General Public License for more details.
From: Stephen Rothwell <hidden> Date: 2012-09-13 08:32:01
Hi Sachin,
On Thu, 13 Sep 2012 13:19:48 +0530 Sachin Kamat [off-list ref] wrote:
quoted
- * This program is distributed in the hope that it will be useful, but
+ * This program is distributed in the hope that it will be useful, butX_ID_MASK
^^^^^^^^^^^^^
Looks like a stray paste..
Yeah, thanks. I will sort it out tomorrow.
--
Cheers,
Stephen Rothwell sfr@canb.auug.org.au
From: Andrew Morton <akpm@linux-foundation.org> Date: 2012-09-13 07:51:35
On Thu, 13 Sep 2012 17:44:41 +1000 Stephen Rothwell [off-list ref] wrote:
quoted hunk
Hi Andrew,
After merging the akpm tree, today's linux-next build (x86_64
allmodconfig) failed like this:
drivers/thermal/cpu_cooling.c: In function 'get_idr':
drivers/thermal/cpu_cooling.c:89:14: error: 'MAX_ID_MASK' undeclared (first use in this function)
Caused by commit "idr: rename MAX_LEVEL to MAX_IDR_LEVEL" from the akpm
tree interacting with commit 78edc7cdcf5e ("thermal: add generic cpufreq
cooling implementation") from the thermal tree.
I have applied the following merge fix patch and can carry it as
necessary.
...
From: Stephen Rothwell <hidden> Date: 2012-09-13 08:31:14
Hi Andrew,
On Thu, 13 Sep 2012 00:56:57 -0700 Andrew Morton [off-list ref] wrote:
On Thu, 13 Sep 2012 17:44:41 +1000 Stephen Rothwell [off-list ref] wrote:
quoted
After merging the akpm tree, today's linux-next build (x86_64
allmodconfig) failed like this:
drivers/thermal/cpu_cooling.c: In function 'get_idr':
drivers/thermal/cpu_cooling.c:89:14: error: 'MAX_ID_MASK' undeclared (first use in this function)
Caused by commit "idr: rename MAX_LEVEL to MAX_IDR_LEVEL" from the akpm
tree interacting with commit 78edc7cdcf5e ("thermal: add generic cpufreq
cooling implementation") from the thermal tree.
I have applied the following merge fix patch and can carry it as
necessary.
...
So, ignore the first hunk above, that was my typo.
Here is the chunk of the series file I have:
idr-rename-max_level-to-max_idr_level.patch
idr-rename-max_level-to-max_idr_level-fix.patch
idr-rename-max_level-to-max_idr_level-fix-fix-2.patch
#NEXT_PATCHES_END
#
linux-next.patch
i-need-old-gcc.patch
idr-rename-max_level-to-max_idr_level-fix-3.patch
arch-alpha-kernel-systblss-remove-debug-check.patch
#
#NEXT_PATCHES_START linux-next-urgent
So idr-rename-max_level-to-max_idr_level-fix-3.patch is excluded form
linux-next :-( I guess I need to just move that further down in the
series file? Though when you send the preceding three patches to Linus,
that fix-3 patch will be needed when I merge the thermal tree.
--
Cheers,
Stephen Rothwell sfr@canb.auug.org.au
From: Stephen Rothwell <hidden> Date: 2012-09-13 23:07:35
Hi Andrew,
On Thu, 13 Sep 2012 18:31:06 +1000 Stephen Rothwell [off-list ref] wrote:
Here is the chunk of the series file I have:
idr-rename-max_level-to-max_idr_level.patch
idr-rename-max_level-to-max_idr_level-fix.patch
idr-rename-max_level-to-max_idr_level-fix-fix-2.patch
#NEXT_PATCHES_END
#
linux-next.patch
i-need-old-gcc.patch
idr-rename-max_level-to-max_idr_level-fix-3.patch
arch-alpha-kernel-systblss-remove-debug-check.patch
#
#NEXT_PATCHES_START linux-next-urgent
So idr-rename-max_level-to-max_idr_level-fix-3.patch is excluded form
linux-next :-( I guess I need to just move that further down in the
series file? Though when you send the preceding three patches to Linus,
that fix-3 patch will be needed when I merge the thermal tree.
I put idr-rename-max_level-to-max_idr_level-fix-3.patch into the akpm
tree in linux-next (just after the -fix-2 patch).
--
Cheers,
Stephen Rothwell sfr@canb.auug.org.au
Hi, all,
On 四, 2012-09-13 at 17:44 +1000, Stephen Rothwell wrote:
Hi Andrew,
After merging the akpm tree, today's linux-next build (x86_64
allmodconfig) failed like this:
drivers/thermal/cpu_cooling.c: In function 'get_idr':
drivers/thermal/cpu_cooling.c:89:14: error: 'MAX_ID_MASK' undeclared (first use in this function)
Caused by commit "idr: rename MAX_LEVEL to MAX_IDR_LEVEL" from the akpm
tree interacting with commit 78edc7cdcf5e ("thermal: add generic cpufreq
cooling implementation") from the thermal tree.
I have applied the following merge fix patch and can carry it as
necessary.
From: Stephen Rothwell <redacted>
Date: Thu, 13 Sep 2012 17:42:11 +1000
Subject: [PATCH] thermal: fix up for MAX_ID_MASK rename
Signed-off-by: Stephen Rothwell <redacted>
thanks for the fix.
I'm new as a git owner, so a stupid question here,
in this case, who should keep this fix? Do I need to do something when
sending pull request?
thanks,
rui