Re: [PATCH 1/5] mm: correct SECTION_SHIFT name in code comments
From: Yu Zhao <hidden>
Date: 2021-05-17 17:18:37
Also in:
lkml
On Mon, May 17, 2021 at 5:21 AM Dong Aisheng [off-list ref] wrote:
quoted hunk ↗ jump to hunk
Actually SECTIONS_SHIFT is used in the kernel code, fixed the code comments. BTW, also moved the code comment to where it's defined. Also fixed a checkpatch complain derived from the original code: WARNING: please, no space before tabs + * SECTIONS_SHIFT ^I^I#bits space required to store a section #$ Cc: Andrew Morton <akpm@linux-foundation.org> Cc: Yu Zhao <redacted> Cc: Andrey Konovalov <andreyknvl@gmail.com> Cc: Catalin Marinas <catalin.marinas@arm.com> Cc: Kees Cook <redacted> Signed-off-by: Dong Aisheng <aisheng.dong@nxp.com> --- include/linux/mmzone.h | 2 -- include/linux/page-flags-layout.h | 3 +++ 2 files changed, 3 insertions(+), 2 deletions(-)diff --git a/include/linux/mmzone.h b/include/linux/mmzone.h index 9cdc88d09f2b..fc23e36cb165 100644 --- a/include/linux/mmzone.h +++ b/include/linux/mmzone.h@@ -1198,8 +1198,6 @@ static inline struct zoneref *first_zones_zonelist(struct zonelist *zonelist, #ifdef CONFIG_SPARSEMEM /* - * SECTION_SHIFT #bits space required to store a section # - * * PA_SECTION_SHIFT physical address to/from section number * PFN_SECTION_SHIFT pfn to/from section number */diff --git a/include/linux/page-flags-layout.h b/include/linux/page-flags-layout.h index ef1e3e736e14..aff616855492 100644 --- a/include/linux/page-flags-layout.h +++ b/include/linux/page-flags-layout.h@@ -26,6 +26,9 @@ #define ZONES_WIDTH ZONES_SHIFT +/* + * SECTIONS_SHIFT #bits space required to store a section # + */
IMO, we should either make the original comment helpful or just remove it. Moving it here doesn't improve readability because it's stating the obvious.
#ifdef CONFIG_SPARSEMEM #include <asm/sparsemem.h> #define SECTIONS_SHIFT (MAX_PHYSMEM_BITS - SECTION_SIZE_BITS) -- 2.25.1