Re: [PATCH v2 3/3] mm: use PF_ONLY_HEAD for PG_active and PG_unevictable
From: Matthew Wilcox <willy@infradead.org>
Date: 2021-03-02 06:40:32
Also in:
lkml
On Mon, Mar 01, 2021 at 12:16:19PM -0800, Hugh Dickins wrote:
On Mon, 1 Mar 2021, Yu Zhao wrote:quoted
On Mon, Mar 01, 2021 at 02:50:07PM +0300, Kirill A. Shutemov wrote:quoted
On Fri, Feb 26, 2021 at 12:13:14PM +0000, Matthew Wilcox wrote:quoted
On Fri, Feb 26, 2021 at 02:17:18AM -0700, Yu Zhao wrote:quoted
All places but one test, set or clear PG_active and PG_unevictable on small or head pages. Use compound_head() explicitly for that singleton so the rest can rid of redundant compound_head().How do you know it's only one place? I really wish you'd work with me on folios. They make the compiler prove that it's not a tail page.+1 to this. The problem with compound_head() is systemic and ad-hoc solution to few page flags will only complicate the picture.Well, I call it an incremental improvement, and how exactly does it complicate the picture? I see your point: you prefer a complete replacement. But my point is not about the preference; it's about presenting an option: I'm not saying we have to go with this series; I'm saying if you don't want to wait, here is something quick but not perfect.+1 to this.
page folios are here and ready to go. I'm doing another pass on them, quantifying the improvements to text with each patch. So far I'm at 4357 bytes of text saved, in the first 10 patches (many of which look as if they're not going to produce any savings). Yu Zhao's patches seem risky. The only way to know if any places have been missed is by enabling CONFIG_DEBUG_VM_PGFLAGS, which we do not recommend for production environments.