Re: [PATCH 0/6] Boot-time switching between 4- and 5-level paging for 4.15, Part 1
From: Ingo Molnar <mingo@kernel.org>
Date: 2017-10-24 09:41:13
Also in:
lkml
* Kirill A. Shutemov [off-list ref] wrote:
On Mon, Oct 23, 2017 at 02:40:14PM +0200, Ingo Molnar wrote:quoted
* Kirill A. Shutemov [off-list ref] wrote:quoted
quoted
Making a variable that 'looks' like a constant macro dynamic in a rare Kconfig scenario is asking for trouble.We expect boot-time page mode switching to be enabled in kernel of next generation enterprise distros. It shoudn't be that rare.My point remains even with not-so-rare Kconfig dependency.I don't follow how introducing new variable that depends on Kconfig option would help with the situation.
A new, properly named variable or function (max_physmem_bits or max_physmem_bits()) that is not all uppercase would make it abundantly clear that it is not a constant but a runtime value.
We would end up with inverse situation: people would use MAX_PHYSMEM_BITS where the new variable need to be used and we will in the same situation.
It should result in sub-optimal resource allocations worst-case, right? We could also rename it to MAX_POSSIBLE_PHYSMEM_BITS to make it clear that the real number of bits can be lower. Thanks, Ingo -- To unsubscribe, send a message with 'unsubscribe linux-mm' in the body to majordomo@kvack.org. For more info on Linux MM, see: http://www.linux-mm.org/ . Don't email: <a href=mailto:"dont@kvack.org"> email@kvack.org </a>