Re: [PATCH] mm: simplify node/zone name printing
From: Petr Mladek <pmladek@suse.com>
Date: 2016-12-19 10:05:53
Also in:
lkml
On Mon 2016-12-19 08:00:47, Vlastimil Babka wrote:
On 12/16/2016 01:32 PM, Michal Hocko wrote:quoted
From: Michal Hocko <mhocko@suse.com> show_node currently only prints Node id while it is always followed by printing zone->name. As the node information is conditional to CONFIG_NUMA we have to be careful to always terminate the previous continuation line before printing the zone name. This is quite ugly and easy to mess up. Let's rename show_node to show_zone_node and make sure that it will always start at a new line. We can drop the ugly printk(KERN_CONT "\n") from show_free_areas. Signed-off-by: Michal Hocko <mhocko@suse.com>quoted
diff --git a/mm/page_alloc.c b/mm/page_alloc.c index 3f2c9e535f7f..5324efa8b9d0 100644 --- a/mm/page_alloc.c +++ b/mm/page_alloc.c@@ -4120,10 +4120,12 @@ unsigned long nr_free_pagecache_pages(void) return nr_free_zone_pages(gfp_zone(GFP_HIGHUSER_MOVABLE)); } -static inline void show_node(struct zone *zone) +static inline void show_zone_node(struct zone *zone) { if (IS_ENABLED(CONFIG_NUMA)) - printk("Node %d ", zone_to_nid(zone)); + printk("Node %d %s", zone_to_nid(zone), zone->name); + else + printk("%s: ", zone->name); } long si_mem_available(void)@@ -4371,9 +4373,8 @@ void show_free_areas(unsigned int filter) for_each_online_cpu(cpu) free_pcp += per_cpu_ptr(zone->pageset, cpu)->pcp.count; - show_node(zone); + show_zone_node(zone); printk(KERN_CONT - "%s"
The new code will printk "%s: " when called with disabled CONFIG_NUMA. Is the added ": " OK? Best Regards, Petr -- To unsubscribe, send a message with 'unsubscribe linux-mm' in the body to majordomo@kvack.org. For more info on Linux MM, see: http://www.linux-mm.org/ . Don't email: <a href=mailto:"dont@kvack.org"> email@kvack.org </a>