Thread (67 messages) 67 messages, 6 authors, 2016-06-24

Re: [PATCH 07/10] mm: base LRU balancing on an explicit cost model

From: Michal Hocko <mhocko@kernel.org>
Date: 2016-06-09 12:18:08
Also in: lkml

On Wed 08-06-16 12:16:05, Johannes Weiner wrote:
On Wed, Jun 08, 2016 at 02:51:37PM +0200, Michal Hocko wrote:
quoted
On Mon 06-06-16 15:48:33, Johannes Weiner wrote:
quoted
Rename struct zone_reclaim_stat to struct lru_cost, and move from two
separate value ratios for the LRU lists to a relative LRU cost metric
with a shared denominator.
I just do not like the too generic `number'. I guess cost or price would
fit better and look better in the code as well. Up you though...
Yeah, I picked it as a pair, numerator and denominator. But as Minchan
points out, denom is superfluous in the final version of the patch, so
I'm going to remove it and give the numerators better names.

anon_cost and file_cost?
Yes that is much more descriptive and easier to grep for. I didn't
propose that because I thought you would want to preserve the array
definition for an easier code to update them.

-- 
Michal Hocko
SUSE Labs

--
To unsubscribe, send a message with 'unsubscribe linux-mm' in
the body to majordomo@kvack.org.  For more info on Linux MM,
see: http://www.linux-mm.org/ .
Don't email: <a href=mailto:"dont@kvack.org"> email@kvack.org </a>
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help