Re: [PATCH TRIVIAL] mm: Fix build warning in kmem_cache_create()
From: David Rientjes <rientjes@google.com>
Date: 2012-07-31 02:08:08
Also in:
lkml
From: David Rientjes <rientjes@google.com>
Date: 2012-07-31 02:08:08
Also in:
lkml
On Mon, 30 Jul 2012, Pekka Enberg wrote:
quoted
-Wunused-label is overridden in gcc for a label that is conditionally referenced by using __maybe_unused in the kernel. I'm not sure what's so obscure about out: __maybe_unused Are label attributes really that obsecure?I think they are. The real problem, however, is that label attributes would just paper over the badly thought out control flow in the function and not make the code any better or easier to read.
So much for compromise, I thought we had agreed that at least some of the checks for !name, in_interrupt() or bad size values should be moved out from under the #ifdef CONFIG_DEBUG_VM, but this wasn't done. This discussion would be irrelevent if we actually did what we talked about. -- To unsubscribe, send a message with 'unsubscribe linux-mm' in the body to majordomo@kvack.org. For more info on Linux MM, see: http://www.linux-mm.org/ . Don't email: <a href=mailto:"dont@kvack.org"> email@kvack.org </a>