On Thu, 9 Feb 2012 16:27:41 -0800
Andrew Morton [off-list ref] wrote:
On Wed, 8 Feb 2012 10:51:42 -0500
Naoya Horiguchi [off-list ref] wrote:
quoted
Currently a local variable of pagemap entry in pagemap_pte_range()
is named pfn and typed with u64, but it's not correct (pfn should
be unsigned long.)
This patch introduces special type for pagemap entry and replace
code with it.
Signed-off-by: Naoya Horiguchi <redacted>
Cc: Andrew Morton <akpm@linux-foundation.org>
Changes since v4:
- Rename pme_t to pagemap_entry_t
hm. Why this change? I'd have thought that this should be called
pme_t. And defined in or under pgtable.h, rather than being private to
fs/proc/task_mmu.c.
Ah, he changed the name because I complained "pme_t seems a new page table entry
type.."
Regards,
-Kame
--
To unsubscribe, send a message with 'unsubscribe linux-mm' in
the body to majordomo@kvack.org. For more info on Linux MM,
see: http://www.linux-mm.org/ .
Fight unfair telecom internet charges in Canada: sign http://stopthemeter.ca/
Don't email: <a href=mailto:"dont@kvack.org"> email@kvack.org </a>