Re: [PATCH] thp: tail page refcounting fix #4
From: Andrea Arcangeli <hidden>
Date: 2011-08-29 23:30:59
Also in:
lkml
From: Andrea Arcangeli <hidden>
Date: 2011-08-29 23:30:59
Also in:
lkml
On Mon, Aug 29, 2011 at 03:40:07PM -0700, Michel Lespinasse wrote:
Looks great.
Thanks!
I think some page_mapcount call sites would be easier to read if you took on my tail_page_count() suggestion (so we can casually see it's a refcount rather than mapcount). But you don't have to do it if you don't think it helps. I'm happy enough with the code already :)
I initially tried to do it but I wanted it in internal.h (it's really an internal thing not mean for any driver whatsoever) but then the gup.c files wouldn't see it, so I wasn't sure how to proceed and I dropped it. It's still possible to do it later... -- To unsubscribe, send a message with 'unsubscribe linux-mm' in the body to majordomo@kvack.org. For more info on Linux MM, see: http://www.linux-mm.org/ . Fight unfair telecom internet charges in Canada: sign http://stopthemeter.ca/ Don't email: <a href=mailto:"dont@kvack.org"> email@kvack.org </a>