Re: [patch 3/3]vmscan: cleanup kswapd_try_to_sleep
From: Minchan Kim <hidden>
Date: 2011-07-29 09:39:38
On Thu, Jul 28, 2011 at 04:13:09PM +0800, Shaohua Li wrote:
cleanup kswapd_try_to_sleep() a little bit. Sometimes kswapd doesn't really sleep. In such case, don't call prepare_to_wait/finish_wait. It just wastes CPU. Signed-off-by: Shaohua Li <redacted>
And it increases just code size a little bit even without big benefit of CPU. You said it's cleanup but I doubt how it helps readability. So code itself dosn't have a problem but I don't like it. barrios@barrios-desktop:~/linux-mmotm$ size mm/vmscan.o.old text data bss dec hex filename 10271 30 8 10309 2845 mm/vmscan.o.old barrios@barrios-desktop:~/linux-mmotm$ size mm/vmscan.o text data bss dec hex filename 10287 30 8 10325 2855 mm/vmscan.o -- Kind regards, Minchan Kim -- To unsubscribe, send a message with 'unsubscribe linux-mm' in the body to majordomo@kvack.org. For more info on Linux MM, see: http://www.linux-mm.org/ . Fight unfair telecom internet charges in Canada: sign http://stopthemeter.ca/ Don't email: <a href=mailto:"dont@kvack.org"> email@kvack.org </a>