Re: [rfc][patch 3/4] fs: new truncate sequence
From: Nick Piggin <hidden>
Date: 2009-07-13 11:32:06
Also in:
linux-fsdevel, lkml
On Mon, Jul 13, 2009 at 02:17:55PM +0300, Boaz Harrosh wrote:
On 07/13/2009 12:00 PM, Nick Piggin wrote:quoted
AFAIKS inode_setattr basically is simple_setattr, so I think at some point it should just get renamed to simple_setattr. Adding simple_setattr_nosize or similar helper would be fine too. I don't care much about the exact details... But anyway these things are not so important to this truncate patchset at the moment.I see. So what is the schedule? when are we to convert all FSs?
Well the changes can be back compatible, and there is not too much complexity to support the current system, so I guess it will just be done as soon as somebody writes the patches. But probably it is a good idea to convert any filesystem using ->truncate to the new sequence at the same time (ie. don't just simply add .setattr = simple_setattr, and rely on its calling vmtruncate, but actually DTRT and remove .truncate at the same time). Any patches would be welcome, for any filesystem. Probably it won't exactly be a rapid process, judging by past experience.
quoted
quoted
[BTW these changes are a life saver for me in regard to the kind of things I need to do for pNFS-exports]You mean the truncate patches? Well that's nice to know. I guess it has always been possible just to redefine your own setattr, but now it should be a bit nicer with the truncate helpers...OK, yes redefine .setattr, do the right thing in write_begin/end and the helpers do help a lot, to the point that it was not safe to open-code all this work. The situation is much better after your patchset.
OK good. -- To unsubscribe, send a message with 'unsubscribe linux-mm' in the body to majordomo@kvack.org. For more info on Linux MM, see: http://www.linux-mm.org/ . Don't email: <a href=mailto:"dont@kvack.org"> email@kvack.org </a>