Re: [rfc][patch 3/4] fs: new truncate sequence
From: Boaz Harrosh <hidden>
Date: 2009-07-12 15:00:16
Also in:
linux-fsdevel, lkml
On 07/12/2009 05:47 PM, Christoph Hellwig wrote:
On Sun, Jul 12, 2009 at 11:55:51AM +0300, Boaz Harrosh wrote:quoted
I wish you would split it. one - helper to be called by converted file systems (Which just ignores the ATTR_SIZE) second - to be set into .setattr which does the simple_setsize + above. More clear for FS users like me (and that ugly unmask of ATTR_SIZE) or it's just me?Yeah, that seems be a lot cleaner. But let's wait until we got rid of ->truncate for all filesystems to have the bigger picture.
I want to convert exofs. do you want that I call inode_setattr clearing ATTR_SIZE bit, and at second stage remove the clearing and rename inode_setattr to something else? When it's time to convert exofs, tel me I'll do it. I have dependent work on top of that, and I want to cleanup the delete_inode as well as some other leftovers. (BTW For none-buffer-heads systems like exofs the new way makes lots of sense) Thanks Boaz -- To unsubscribe, send a message with 'unsubscribe linux-mm' in the body to majordomo@kvack.org. For more info on Linux MM, see: http://www.linux-mm.org/ . Don't email: <a href=mailto:"dont@kvack.org"> email@kvack.org </a>