Re: Extend clear_page by an order parameter
From: Paul Mackerras <hidden>
Date: 2005-01-22 02:53:46
Also in:
lkml
Christoph Lameter writes:
I had the name "zero_page" in V1 and V2 of the patch where it was separate. Then someone complained about code duplication.
Well, if you duplicated each arch's clear_page implementation in zero_page, then yes, that would be unnecessary code duplication. I would suggest that for architectures where the clear_page implementation can easily be extended, rename it to clear_page_order (or something) and #define clear_page(x) to be clear_page_order(x, 0). For architectures where it can't, leave clear_page as clear_page and define clear_page_order as an inline function that calls clear_page in a loop.
clear_page is called clear_page because it clears one page of *any* order not just higher orders. zero-order pages are not segregated nor are they intrisincally better just because they contain more memory ;-).
You have missed my point, which was about address constraints, not a distinction between zero-order pages and higher-order pages. Anyway, I remain of the opinion that your naming is inconsistent with the naming of other functions that deal with zero-order and higher-order pages, such as get_free_pages, alloc_pages, free_pages, etc., and that your patch is unnecessarily intrusive. I guess it's up to Andrew to decide which way we go. Paul. -- To unsubscribe, send a message with 'unsubscribe linux-mm' in the body to majordomo@kvack.org. For more info on Linux MM, see: http://www.linux-mm.org/ . Don't email: <a href=mailto:"aart@kvack.org"> aart@kvack.org </a>