Re: Extend clear_page by an order parameter
From: Christoph Lameter <hidden>
Date: 2005-01-22 01:54:57
Also in:
lkml
On Sat, 22 Jan 2005, Paul Mackerras wrote:
Christoph's patch is bigger than it needs to be because he has to change all the occurrences of clear_page(x) to clear_page(x, 0), and then he has to change a lot of architectures' clear_page functions to be called _clear_page instead. If he picked a different name for the "clear a higher order page" function it would end up being less invasive as well as less confusing.
I had the name "zero_page" in V1 and V2 of the patch where it was separate. Then someone complained about code duplication.
The argument that clear_page is called that because it clears a higher order page won't wash; all the clear_page implementations in his patch are perfectly capable of clearing any contiguous set of 2^order pages (oops, I mean "zero-order pages"), not just a "higher order page".
clear_page is called clear_page because it clears one page of *any* order not just higher orders. zero-order pages are not segregated nor are they intrisincally better just because they contain more memory ;-). -- To unsubscribe, send a message with 'unsubscribe linux-mm' in the body to majordomo@kvack.org. For more info on Linux MM, see: http://www.linux-mm.org/ . Don't email: <a href=mailto:"aart@kvack.org"> aart@kvack.org </a>