Thread (5 messages) 5 messages, 4 authors, 2003-03-04

Re: [PATCH] remove __pte_offset

From: Andrew Morton <hidden>
Date: 2003-03-04 23:26:51

"Martin J. Bligh" [off-list ref] wrote:
quoted
quoted
ptes this time
Isn't pte_to_pfn a better name?  index doesn't have a type of data 
implied, whereas pfn does.  We have to make these distinctions clearer 
as work like William's PAGE_SIZE is being done.
For pte_index? Surely they're completely separate things?
Yes, they are.  A pfn is a fairly distinct thing with "meaning".
pte_index returns a virtual address offset into the pte, and
pte index into the pagetable page <thwap>
pte_to_pfn returns a physical address?
pageframe number.
--
To unsubscribe, send a message with 'unsubscribe linux-mm' in
the body to majordomo@kvack.org.  For more info on Linux MM,
see: http://www.linux-mm.org/ .
Don't email: <a href=mailto:"aart@kvack.org">aart@kvack.org</a>
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help