Re: [PATCH] remove __pte_offset
From: Dave Hansen <hidden>
Date: 2003-03-04 23:25:13
Martin J. Bligh wrote:
quoted
quoted
ptes this timeIsn't pte_to_pfn a better name? index doesn't have a type of data implied, whereas pfn does. We have to make these distinctions clearer as work like William's PAGE_SIZE is being done.For pte_index? Surely they're completely separate things? pte_index returns a virtual address offset into the pte, and pte_to_pfn returns a physical address?
Yeah, Martin's right. I jumped the gun with that second patch
#define pte_index(address) \
(((address) >> PAGE_SHIFT) & (PTRS_PER_PTE - 1))
We _are_ talking about the address and conversion to the index into the
pte page here, not the contents of the pte and thus the pfn.
Please stop confusing me, the voices in my head are bad enough :)
--
Dave Hansen
haveblue@us.ibm.com
--
To unsubscribe, send a message with 'unsubscribe linux-mm' in
the body to majordomo@kvack.org. For more info on Linux MM,
see: http://www.linux-mm.org/ .
Don't email: <a href=mailto:"aart@kvack.org">aart@kvack.org</a>