Re: ISA
From: Maciej W. Rozycki <hidden>
Date: 2001-12-20 15:12:06
On Thu, 20 Dec 2001, Geert Uytterhoeven wrote:
Yes, you have <bus>_ioremap() anyway, since plain ioremap() is for PCI only.
Indeed. But then ioremap() naming is inconsistent -- pci_ioremap() should be defined and used for PCI and ioremap() should be reserved for mapping devices straightly from the CPU's physical space (think devices plugged into CPU's local memory sockets -- I have one here).
And then struct busops starts looking like an interesting direction...
Agreed. -- + Maciej W. Rozycki, Technical University of Gdansk, Poland + +--------------------------------------------------------------+ + e-mail: macro@ds2.pg.gda.pl, PGP key available +