Thread (10 messages) flat view 10 messages, 4 authors, 2016-10-13

Re: [PATCH v4 1/3] skge: Rename LED_OFF and LED_ON in marvel skge driver to avoid conflicts with leds namespace

From: Zach Brown <hidden>
Date: 2016-10-11 23:05:54
Also in: lkml, netdev

On Tue, Oct 11, 2016 at 02:14:07PM -0700, Stephen Hemminger wrote:
On Tue, 11 Oct 2016 15:26:18 -0500
Zach Brown [off-list ref] wrote:
quoted
Adding led support for phy causes namespace conflicts for some
phy drivers.

The marvel skge driver declared an enum for representing the states of
Link LED Register. The enum contained constant LED_OFF which conflicted
with declartation found in linux/leds.h.
LED_OFF changed to LED_REG_OFF
Also changed LED_ON to LED_REG_ON to avoid possible future conflict and
for consistency.

Signed-off-by: Zach Brown <redacted>
Sure, that's fine but not sure why skge would be including linux/leds.h
anyway.
It's pretty convoluted. Here's the chain of includes.
skge -> netdevice -> dsa -> phy -> phy_led_triggers -> leds
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help