Re: [PATCH v4] Documentation: checkpatch: Add SYMBOLIC_PERMS message
From: Lukas Bulwahn <lukas.bulwahn@gmail.com>
Date: 2021-08-23 07:18:51
On Sun, Aug 22, 2021 at 7:52 PM Dwaipayan Ray [off-list ref] wrote:
On Sat, Aug 7, 2021 at 1:41 AM Utkarsh Verma [off-list ref] wrote:quoted
Add a new message type SYMBOLIC_PERMS under the 'Permissions' subsection. Users should use octal permission bits instead of their symbolic macro names.Like Lukas said, the reader could use a better explanation as to why octal permission bits are preferred.
I think this patch could deserve another iteration addressing my comment. If that then reads worse than before, we simply take this patch, but we should at least give it a try. The referred email discussion can be probably quickly summarized (without the more emotional aspect of the discussion). Lukas
However, I think this message shall be fine too as it's pretty much self-explanatory. So, with that: Reviewed-by: Dwaipayan Ray <dwaipayanray1@gmail.com>quoted
Suggested-by: Lukas Bulwahn <lukas.bulwahn@gmail.com> Signed-off-by: Utkarsh Verma <redacted> --- Documentation/dev-tools/checkpatch.rst | 6 ++++++ 1 file changed, 6 insertions(+)diff --git a/Documentation/dev-tools/checkpatch.rst b/Documentation/dev-tools/checkpatch.rst index f0956e9ea..009957cda 100644 --- a/Documentation/dev-tools/checkpatch.rst +++ b/Documentation/dev-tools/checkpatch.rst@@ -957,6 +957,12 @@ Permissions Permission bits should use 4 digit octal permissions (like 0700 or 0444). Avoid using any other base like decimal. + **SYMBOLIC_PERMS** + Permission bits in the octal form are more readable and easier to + understand than their symbolic counterparts. + + See: https://lore.kernel.org/lkml/CA+55aFw5v23T-zvDZp-MmD_EYxF8WbafwwB59934FV7g21uMGQ@mail.gmail.com/ + Spacing and Brackets -------------------- --2.17.1
_______________________________________________ Linux-kernel-mentees mailing list Linux-kernel-mentees@lists.linuxfoundation.org https://lists.linuxfoundation.org/mailman/listinfo/linux-kernel-mentees