Le 7 oct. 2012 à 18:07, Benjamin Tissoires a écrit :
quoted
quoted
Basically, to me this all boils down to the question -- what is more
important: low-level transport being used, or the general function of the
device?
To me, it's the latter, and as such, everything would belong under
drivers/hid.
Then shouldn't is be drivers/input, rather?
Ouch, it will introduce more and more complexity.
Purely rhetorical question, I agree. But still.
It seems that hid transport layers should go in drivers/hid.
However, I don't like mixing the transport layer and the final
drivers. Maybe this is the time to rework a little bit the tree.
To minimize the moves, we could introduce:
drivers/hid/busses/usb
drivers/hid/busses/i2c
drivers/hid/busses/bluetooth
What about creating drivers/hid/core and move all generic stuff there? That is:
drivers/hid/core
drivers/hid/usb
drivers/hid/i2c
drivers/hid/bluetooth
Cheers,
St.