From: Benjamin Tissoires <hidden> Date: 2011-01-28 16:04:56
The safest quirk for a device (the one that works out of the box for
most of them) is the MT_QUIRK_NOT_SEEN_MEANS_UP. Indeed, it does not
make any assumption on the device. When adding a new device, we can
easily test it against MT_CLS_DEFAULT, and then optimize it with other
quirks: that's why no device use MT_CLS_DEFAULT right now.
This patch introduce also MT_CLS_DUAL_DEFAULT which has the same purpose
than MT_CLS_DEFAULT, but for dual touch panels.
Finally, the patch renames MT_CLS_DUAL1 to MT_CLS_DUAL_INRANGE_CONTACTID
and MT_CLS_DUAL2 to MT_CLS_DUAL_INRANGE_CONTACTNUMBER for better
readability.
Signed-off-by: Benjamin Tissoires <redacted>
---
drivers/hid/hid-multitouch.c | 25 +++++++++++++++----------
1 files changed, 15 insertions(+), 10 deletions(-)
From: Benjamin Tissoires <hidden> Date: 2011-01-28 16:05:10
The product id is the 42 inches one. I don't know if they have
other product id for the other size, or if it is a per-size product id.
Tested-by: Victor Zhuk <redacted>
Signed-off-by: Benjamin Tissoires <redacted>
---
drivers/hid/Kconfig | 1 +
drivers/hid/hid-ids.h | 3 +++
drivers/hid/hid-multitouch.c | 5 +++++
3 files changed, 9 insertions(+), 0 deletions(-)
The product id is the 42 inches one. I don't know if they have
other product id for the other size, or if it is a per-size product id.
This is very interesting, I have access to a 65" IrTouch system which
has VID 0x6615 and PID 0x0C20. I wasn't aware that there are already
kernel drivers for their systems, I had been playing around with their
awful binary driver and had done some experiments with libusb. Is there
a documentation of some kind available?
I will test this on our screen next week.
I assume that I should use the tree from:
http://git.kernel.org/?p=linux/kernel/git/rydberg/input-mt.git;a=summary
Note: after briefly browsing through hid-multitouch.c, it seems to me
that there might be issues; the USB interface on our screen doesn't
report as HID device, but as vendor class (0xFF).
Florian
From: Benjamin Tissoires <hidden> Date: 2011-01-28 16:59:43
Hi Florian,
On Fri, Jan 28, 2011 at 17:24, Florian Echtler [off-list ref] wrote:
Hello everyone,
quoted
The product id is the 42 inches one. I don't know if they have
other product id for the other size, or if it is a per-size product id.
This is very interesting, I have access to a 65" IrTouch system which
has VID 0x6615 and PID 0x0C20. I wasn't aware that there are already
kernel drivers for their systems, I had been playing around with their
awful binary driver and had done some experiments with libusb. Is there
a documentation of some kind available?
We just made the analysis of the hid reports that are send. We have no
documentation for this particular device.
Note: after briefly browsing through hid-multitouch.c, it seems to me
that there might be issues; the USB interface on our screen doesn't
report as HID device, but as vendor class (0xFF).
This is more problematic. Hardware makers are forced to push hid aware
firmware to be win7 certified. Maybe they have a new firmware for your
device.
Cheers,
Benjamin
--
To unsubscribe from this list: send the line "unsubscribe linux-input" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
From: Henrik Rydberg <hidden> Date: 2011-01-28 17:18:59
Hi Benjamin,
The safest quirk for a device (the one that works out of the box for
most of them) is the MT_QUIRK_NOT_SEEN_MEANS_UP. Indeed, it does not
make any assumption on the device. When adding a new device, we can
easily test it against MT_CLS_DEFAULT, and then optimize it with other
quirks: that's why no device use MT_CLS_DEFAULT right now.
This patch introduce also MT_CLS_DUAL_DEFAULT which has the same purpose
than MT_CLS_DEFAULT, but for dual touch panels.
But it is used anywhere?
Finally, the patch renames MT_CLS_DUAL1 to MT_CLS_DUAL_INRANGE_CONTACTID
and MT_CLS_DUAL2 to MT_CLS_DUAL_INRANGE_CONTACTNUMBER for better
readability.
Signed-off-by: Benjamin Tissoires <redacted>
---
The patch description and the content lacks a certain
distinctness. Please single out janitory actions into a separate
patch, or, if possible, skip it altogether.
From: Henrik Rydberg <hidden> Date: 2011-01-28 17:21:07
On Fri, Jan 28, 2011 at 05:04:40PM +0100, Benjamin Tissoires wrote:
The product id is the 42 inches one. I don't know if they have
other product id for the other size, or if it is a per-size product id.
Tested-by: Victor Zhuk <redacted>
Signed-off-by: Benjamin Tissoires <redacted>
---
The canonical patch description presents the reason for the change,
and what the patch does (not necessarily how).
From: Benjamin Tissoires <hidden> Date: 2011-01-28 17:52:39
On Fri, Jan 28, 2011 at 18:18, Henrik Rydberg [off-list ref] wrote:
Hi Benjamin,
quoted
The safest quirk for a device (the one that works out of the box for
most of them) is the MT_QUIRK_NOT_SEEN_MEANS_UP. Indeed, it does not
make any assumption on the device. When adding a new device, we can
easily test it against MT_CLS_DEFAULT, and then optimize it with other
quirks: that's why no device use MT_CLS_DEFAULT right now.
This patch introduce also MT_CLS_DUAL_DEFAULT which has the same purpose
than MT_CLS_DEFAULT, but for dual touch panels.
But it is used anywhere?
Hi Henrik,
In it's current form, no. I often rely on it to make a quick patch
(just adding the ids in hid-ids, hid-core and hid-multitouch) to test
a new (dual touch) device. I thought it would be useful to be
mainstream.
quoted
Finally, the patch renames MT_CLS_DUAL1 to MT_CLS_DUAL_INRANGE_CONTACTID
and MT_CLS_DUAL2 to MT_CLS_DUAL_INRANGE_CONTACTNUMBER for better
readability.
Signed-off-by: Benjamin Tissoires <redacted>
---
The patch description and the content lacks a certain
distinctness. Please single out janitory actions into a separate
patch, or, if possible, skip it altogether.
There is no need to change the numbering for unchanged names.
I just wanted to keep device-specific at the end of the list. Hence
the 10 to keep a little space between generic and devices:
MT_CLS_DUAL_CONFIDENCE_CONTACT* are coming...
quoted
/*
* these device-dependent functions determine what slot corresponds
@@ -104,13 +106,16 @@ static int find_slot_from_contactid(struct mt_device *td)
Thanks for the review,
Benjamin
--
To unsubscribe from this list: send the line "unsubscribe linux-input" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
From: Benjamin Tissoires <hidden> Date: 2011-01-28 17:59:16
On Fri, Jan 28, 2011 at 18:21, Henrik Rydberg [off-list ref] wrote:
On Fri, Jan 28, 2011 at 05:04:40PM +0100, Benjamin Tissoires wrote:
quoted
The product id is the 42 inches one. I don't know if they have
other product id for the other size, or if it is a per-size product id.
Tested-by: Victor Zhuk <redacted>
Signed-off-by: Benjamin Tissoires <redacted>
---
The canonical patch description presents the reason for the change,
and what the patch does (not necessarily how).
It was just to keep trace of the kind of display it was. As Florian
told the 63" does not have the same PID but not also the same
protocol.
Otherwise, we can also change the name of the define, but I'm not sure
on the rule to apply here.
Thanks,
Benjamin
Say Y here if you have one of the following devices:
- Cypress TrueTouch panels
- Hanvon dual touch panels
+ - IrTouch Infrared USB panels
- Pixcir dual touch panels
- 'Sensing Win7-TwoFinger' panel by GeneralTouch
--
To unsubscribe from this list: send the line "unsubscribe linux-input" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
From: Henrik Rydberg <hidden> Date: 2011-01-28 18:42:38
quoted
quoted
This patch introduce also MT_CLS_DUAL_DEFAULT which has the same purpose
than MT_CLS_DEFAULT, but for dual touch panels.
But it is used anywhere?
Hi Henrik,
In it's current form, no. I often rely on it to make a quick patch
(just adding the ids in hid-ids, hid-core and hid-multitouch) to test
a new (dual touch) device. I thought it would be useful to be
mainstream.
I see. However, it is just as easy to keep as a local patch. Quite
generally, there really is a difference between what we do in our
computers and what ends up in mainline, and it is almost always for a
good reason.
There is no need to change the numbering for unchanged names.
I just wanted to keep device-specific at the end of the list. Hence
the 10 to keep a little space between generic and devices:
MT_CLS_DUAL_CONFIDENCE_CONTACT* are coming...
It is very often the case that one would like to modify something to
keep to a certain aesthetic classification or idea, but there is a
very good reason not to do it. In order to maintain more than one
branch, for instance a stable tree and several distributions, having
simple patches makes a huge difference in maintenance burden. Not to
mention how hard it can be to merge trees with unrelated changes in
them. So please, keep patches short, sweet and to the point.
Thanks,
Henrik
--
To unsubscribe from this list: send the line "unsubscribe linux-input" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
From: Henrik Rydberg <hidden> Date: 2011-01-28 18:49:15
On Fri, Jan 28, 2011 at 06:59:13PM +0100, Benjamin Tissoires wrote:
On Fri, Jan 28, 2011 at 18:21, Henrik Rydberg [off-list ref] wrote:
quoted
On Fri, Jan 28, 2011 at 05:04:40PM +0100, Benjamin Tissoires wrote:
quoted
The product id is the 42 inches one. I don't know if they have
other product id for the other size, or if it is a per-size product id.
Tested-by: Victor Zhuk <redacted>
Signed-off-by: Benjamin Tissoires <redacted>
---
The canonical patch description presents the reason for the change,
and what the patch does (not necessarily how).
It was just to keep trace of the kind of display it was. As Florian
told the 63" does not have the same PID but not also the same
protocol.
Otherwise, we can also change the name of the define, but I'm not sure
on the rule to apply here.
Oh, I meant the patch description simply needs to be a bit more
self-contained. Keeping special information as what you write is
great, it just needs to in addition tell things like: "The IrTouch
infrared panels currently lack kernel support", and/or "This patch
adds support for IrTouch 42''".
Thanks,
Henrik