Thread (23 messages) 23 messages, 3 authors, 2009-02-27

Re: [PATCH 0/10] ide: flags query macros

flat view

From: Bartlomiej Zolnierkiewicz <bzolnier@gmail.com>
Date: 2009-02-16 22:17:03
Also in: lkml

On Sunday 15 February 2009, Borislav Petkov wrote:
Hi,

this series adds the drive->atapi_flags and drive->dev_flags macro wrappers
we discussed. The idea was to make the code more readable and this has
Fine...
been my main concern when coming up with the macro naming, therefore
some macro names appear a tad more descriptive than the flag itself.
...but this part destroys consistency in the process.

If you think that some flag names should be fixed please just fix them
(or just leave them alone -- I think that people invest far too much time
into fixing all these minor things while tend to fix themselves when the
big things are being fixed).

Also ide_drv_ is bad name for ->{dev,atapi}_flags (drv == "driver" for
most people not "drive") -- please make it either ide_dev_ or ide_dflag_.

Thanks,
Bart
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help