[PATCH 0/10] ide: flags query macros
flat view
STALE6435d
From: Borislav Petkov <hidden>
Date: 2009-02-15 12:08:58
Also in:
lkml
Hi, this series adds the drive->atapi_flags and drive->dev_flags macro wrappers we discussed. The idea was to make the code more readable and this has been my main concern when coming up with the macro naming, therefore some macro names appear a tad more descriptive than the flag itself. drivers/ide/cmd640.c | 2 +- drivers/ide/ht6560b.c | 3 +- drivers/ide/ide-atapi.c | 15 ++++++------- drivers/ide/ide-cd.c | 44 ++++++++++++++++++++------------------- drivers/ide/ide-cd_ioctl.c | 18 +++++++--------- drivers/ide/ide-devsets.c | 8 ++---- drivers/ide/ide-disk.c | 32 ++++++++++++++-------------- drivers/ide/ide-disk_proc.c | 2 +- drivers/ide/ide-dma.c | 3 +- drivers/ide/ide-eh.c | 17 +++++++-------- drivers/ide/ide-floppy.c | 6 ++-- drivers/ide/ide-floppy_ioctl.c | 2 +- drivers/ide/ide-gd.c | 14 ++++++------ drivers/ide/ide-io.c | 9 +++---- drivers/ide/ide-ioctls.c | 6 ++-- drivers/ide/ide-iops.c | 6 ++-- drivers/ide/ide-lib.c | 2 +- drivers/ide/ide-park.c | 11 ++++----- drivers/ide/ide-pm.c | 2 +- drivers/ide/ide-probe.c | 36 +++++++++++++++++--------------- drivers/ide/ide-proc.c | 2 +- drivers/ide/ide-tape.c | 12 +++++----- drivers/ide/ide-taskfile.c | 16 +++++--------- drivers/ide/ns87415.c | 5 +-- drivers/ide/pdc202xx_old.c | 4 +- drivers/ide/sc1200.c | 2 +- drivers/ide/trm290.c | 4 +- 27 files changed, 136 insertions(+), 147 deletions(-)