Re: [PATCH 1/2] i2c: Add message transfer tracepoints for I2C

From
Wolfram Sang <hidden>
Date
2014-02-28 21:18:08
Also in
lkml
Reply to
David Howells, 2014-02-27
quoted
And for the buffer: %*phN is difficult to read IMO. What about %*ph? Or
%*phD at least?
My problem with that is that it increases the length of the output by 50% and
there's a hard limit on how much output we may produce.
Is it PAGE_SIZE? How is this handled when the buffer is so big that the
limit will be reached anyhow? Note that it is really uncommon to
transfer kilobytes in one go via i2c. Usually, big transfers are split
up into smaller fragments, say 128-256 byte. So, for readability, I'd
still favour %*ph.

Attachments

Thread (14 messages) 14 messages, 2 authors, last reply 2014-03-06
Keyboard shortcuts
hback out one level
jnext message in thread / next series-diff position
kprevious message in thread / previous series-diff position
ldrill in
Escclose help / fold thread tree
?toggle this help