Hi Christoph,
On Mon, Sep 20, 2021 at 4:09 PM Christoph Hellwig [off-list ref] wrote:
On Mon, Sep 20, 2021 at 04:05:03PM +0200, Bartosz Golaszewski wrote:
quoted
For better readability and maintenance: use the BIT() macro for flag
definitions.
NAK. BIT() is the stupidest macro in the kernel and shall not be used
ever. And I'm pretty sure we had this discussion a few times.
Care to explain why it is a stupid macro?
TIA!
Gr{oetje,eeting}s,
Geert
--
Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- geert@linux-m68k.org
In personal conversations with technical people, I call myself a hacker. But
when I'm talking to journalists I just say "programmer" or something like that.
-- Linus Torvalds