Thread (15 messages) 15 messages, 5 authors, 2021-02-11

Re: [PATCH for next v1 1/2] gpio: omap: Replace raw_spin_lock_irqsave with raw_spin_lock in omap_gpio_irq_handler()

From: Grygorii Strashko <grygorii.strashko@ti.com>
Date: 2021-02-11 20:19:50
Also in: lkml


On 11/02/2021 21:39, Arnd Bergmann wrote:
On Thu, Feb 11, 2021 at 7:25 PM Grygorii Strashko
[off-list ref] wrote:
quoted
On 08/02/2021 10:56, Luo Jiaxing wrote:
quoted
There is no need to use API with _irqsave in omap_gpio_irq_handler(),
because it already be in a irq-disabled context.
NACK.
Who said that this is always hard IRQ handler?
What about RT-kernel or boot with "threadirqs"?
In those cases, the interrupt handler is just a normal thread, so the
preempt_disable() that is implied by raw_spin_lock() is sufficient.

Disabling interrupts inside of an interrupt handler is always incorrect,
the patch looks like a useful cleanup to me, if only for readability.
Note. there is also generic_handle_irq() call inside.

-- 
Best regards,
grygorii
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help