Thread (18 messages) 18 messages, 7 authors, 2021-01-06

Re: [PATCH 4/5] gpio: xilinx: Utilize generic bitmap_get_value and _set_value

From: Michal Simek <hidden>
Date: 2021-01-05 11:05:30
Also in: linux-arch, linux-arm-kernel, linux-pm, lkml

Hi, +Srinivas,

On 27. 12. 20 22:29, Linus Walleij wrote:
On Sat, Dec 26, 2020 at 7:44 AM Syed Nayyar Waris [off-list ref] wrote:
quoted
This patch reimplements the xgpio_set_multiple() function in
drivers/gpio/gpio-xilinx.c to use the new generic functions:
bitmap_get_value() and bitmap_set_value(). The code is now simpler
to read and understand. Moreover, instead of looping for each bit
in xgpio_set_multiple() function, now we can check each channel at
a time and save cycles.

Cc: William Breathitt Gray <redacted>
Cc: Bartosz Golaszewski <redacted>
Cc: Michal Simek <redacted>
Signed-off-by: Syed Nayyar Waris <redacted>
(...)
quoted
+#include <../drivers/gpio/clump_bits.h>
What is this?

Isn't a simple

#include "clump_bits.h"

enough?

We need an ACK from the Xilinx people that they think this
actually improves the readability and maintainability of their
driver.
Srinivas is going to send some patches against this driver. That's why
please take a look if both of these changes are fitting together.

Thanks,
Michal
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help