Hi, +Srinivas,
On 27. 12. 20 22:29, Linus Walleij wrote:
On Sat, Dec 26, 2020 at 7:44 AM Syed Nayyar Waris [off-list ref] wrote:
quoted
This patch reimplements the xgpio_set_multiple() function in
drivers/gpio/gpio-xilinx.c to use the new generic functions:
bitmap_get_value() and bitmap_set_value(). The code is now simpler
to read and understand. Moreover, instead of looping for each bit
in xgpio_set_multiple() function, now we can check each channel at
a time and save cycles.
Cc: William Breathitt Gray <redacted>
Cc: Bartosz Golaszewski <redacted>
Cc: Michal Simek <redacted>
Signed-off-by: Syed Nayyar Waris <redacted>
(...)
quoted
+#include <../drivers/gpio/clump_bits.h>
What is this?
Isn't a simple
#include "clump_bits.h"
enough?
We need an ACK from the Xilinx people that they think this
actually improves the readability and maintainability of their
driver.
Srinivas is going to send some patches against this driver. That's why
please take a look if both of these changes are fitting together.
Thanks,
Michal