Thread (43 messages) 43 messages, 5 authors, 11m ago

Re: [PATCH 07/13] mm/vma: rename vma_get_page_prot to vma_flags_to_page_prot

From: Lance Yang <lance.yang@linux.dev>
Date: 2026-07-02 12:25:49
Also in: dri-devel, intel-gfx, intel-xe, linux-arm-msm, linux-fsdevel, linux-mips, linux-samsung-soc, linux-sound, linux-tegra, linuxppc-dev, lkml, nouveau, virtualization, xen-devel

On Mon, Jun 29, 2026 at 08:25:30PM +0100, Lorenzo Stoakes wrote:
Having vma_get_page_prot() refer to VMA flags and vma_set_page_prot() refer
to a VMA is confusing.

Rename vma_get_page_prot() to vma_flags_to_page_prot() to resolve this
confusion.

No functional change intended.

Signed-off-by: Lorenzo Stoakes <ljs@kernel.org>
---
straight rename, no stale callers that I can spot ;) Feel free to add:

Reviewed-by: Lance Yang <lance.yang@linux.dev>
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help