On Sun, May 18, 2025 at 03:09:47PM -0700, Eric Florin wrote:
quoted hunk ↗ jump to hunk
Rename `dpPortBase` to `dp_port_base` to conform with kernel style
guidelines as reported by checkpatch.pl
CHECK: Avoid CamelCase: <dpPortBase>
Signed-off-by: Eric Florin <redacted>
---
drivers/staging/sm750fb/sm750.h | 2 +-
drivers/staging/sm750fb/sm750_accel.c | 2 +-
drivers/staging/sm750fb/sm750_hw.c | 2 +-
3 files changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/sm750fb/sm750.h b/drivers/staging/sm750fb/sm750.h
index a2342c69a65a..0ed1e18611ba 100644
--- a/drivers/staging/sm750fb/sm750.h
+++ b/drivers/staging/sm750fb/sm750.h
@@ -52,7 +52,7 @@ struct lynx_accel {
/* base virtual address of DPR registers */
volatile unsigned char __iomem *dpr_base;
/* base virtual address of de data port */
- volatile unsigned char __iomem *dpPortBase;
+ volatile unsigned char __iomem *dp_port_base;
Same here, are you sure this doesn't come directly from the hardware
spec?
thanks,
greg k-h