On Wed, Feb 01, 2017 at 03:51:06PM +0100, Linus Walleij wrote:
fwnode_get_named_gpiod()
devm_get_gpiod_from_child()
Both are taking a fwnode as argument and the naming is as
inconsistent as it can be.
Some more churn should be expected as a side
effect of naming this function wrong in the first place.
The fwnode API change was on fast-forward and mistakes
were made, also by me, mea culpa.
The name fwnode_get_named_gpiod() tries to follow of_get_named_gpio() so
that we can easily convert a driver to use fwnodes instead. The other
function is named so because we look child fwnodes under a device. For
that, yes certainly we could have invented a better name ;-)