Thread (20 messages) 20 messages, 5 authors, 2017-02-02

Re: [PATCH 1/2] gpio: Rename devm_get_gpiod_from_child()

From: Dmitry Torokhov <dmitry.torokhov@gmail.com>
Date: 2017-01-31 01:06:14
Also in: linux-gpio, linux-input, linux-leds, lkml

On Mon, Jan 30, 2017 at 04:41:48PM +0100, Boris Brezillon wrote:
Rename devm_get_gpiod_from_child() into
devm_fwnode_get_gpiod_from_child() to reflect the fact that this
function is operating on a fwnode object.
I believe this is completely pointless rename. Are you planning on
adding devm_of_get_gpiod_from_child()? Or
devm_acpt_get_gpiod_from_child()? (I sure hope not).

Also, on what object? Does it take fwnode as first argument? Or maybe we
should call it devm_dev_const_charp_fwnode_get_gpiod_from_child() so we
know types of all arguments?

Please, no.

Thanks.

-- 
Dmitry
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help