[PATCH] backlight-tosa: Delete owner assignment

Subsystems: backlight class/subsystem, framebuffer layer, the rest

STALE3656d

7 messages, 3 authors, 2016-08-17 · open the first message on its own page

[PATCH] backlight-tosa: Delete owner assignment

From: SF Markus Elfring <hidden>
Date: 2016-08-15 11:12:59

From: Markus Elfring <redacted>
Date: Mon, 15 Aug 2016 13:03:29 +0200

The field "owner" is set by core. Thus delete an extra initialisation.

Generated by: scripts/coccinelle/api/platform_no_drv_owner.cocci
Signed-off-by: Markus Elfring <redacted>
---
 drivers/video/backlight/tosa_bl.c | 1 -
 1 file changed, 1 deletion(-)
diff --git a/drivers/video/backlight/tosa_bl.c b/drivers/video/backlight/tosa_bl.c
index 83742d8..9706759 100644
--- a/drivers/video/backlight/tosa_bl.c
+++ b/drivers/video/backlight/tosa_bl.c
@@ -163,7 +163,6 @@ MODULE_DEVICE_TABLE(i2c, tosa_bl_id);
 static struct i2c_driver tosa_bl_driver = {
 	.driver = {
 		.name		= "tosa-bl",
-		.owner		= THIS_MODULE,
 		.pm		= &tosa_bl_pm_ops,
 	},
 	.probe		= tosa_bl_probe,
-- 
2.9.2

Re: [PATCH] backlight-tosa: Delete owner assignment

From: Vegard Nossum <hidden>
Date: 2016-08-15 11:39:11

On 15 August 2016 at 13:12, SF Markus Elfring
[off-list ref] wrote:
From: Markus Elfring <redacted>
Date: Mon, 15 Aug 2016 13:03:29 +0200

The field "owner" is set by core. Thus delete an extra initialisation.
Hi,

Just a small nit on the patch title: "delete owner assignment" is
virtually useless as a title because it has no meaning without the
broader context and only describes the literal change. It's like
naming a patch "add a line" or "change the code"; it serves no
purpose.

How about "backlight-tosa: delete _unnecessary_ assignment"? This
immediately communicates the reason for/intent of the patch (there is
unnecessary code, thus we can simplify it).

(Sorry about singling out this patch and the apparent bikeshedding,
this comment obviously applies to a lot of patches by a lot of
authors!)

Thanks,


Vegard

Re: backlight-tosa: Delete owner assignment

From: SF Markus Elfring <hidden>
Date: 2016-08-15 13:25:54

quoted
The field "owner" is set by core. Thus delete an extra initialisation.
Just a small nit on the patch title: "delete owner assignment" is
virtually useless as a title because it has no meaning without the
broader context and only describes the literal change. It's like
naming a patch "add a line" or "change the code";
it serves no purpose.
I have got an other impression.

Do you want that I add any more background information to the
commit message?

How about "backlight-tosa: delete _unnecessary_ assignment"?
Will the underlined key word trigger any related software
development concerns?

Would another look be needed on how the usage of the mentioned data
structure element was reduced over time?

Regards,
Markus

Re: backlight-tosa: Delete owner assignment

From: Vegard Nossum <hidden>
Date: 2016-08-15 13:37:54

On 15 August 2016 at 15:25, SF Markus Elfring
[off-list ref] wrote:
quoted
quoted
The field "owner" is set by core. Thus delete an extra initialisation.
Just a small nit on the patch title: "delete owner assignment" is
virtually useless as a title because it has no meaning without the
broader context and only describes the literal change. It's like
naming a patch "add a line" or "change the code";
it serves no purpose.
I have got an other impression.

Do you want that I add any more background information to the
commit message?
No, the rest of the commit message is fine. I was only concerned about
the patch title (the first line) since that's what appears frequently
in patch lists (cgit, shortlogs, email/archives), etc.
quoted
How about "backlight-tosa: delete _unnecessary_ assignment"?
Will the underlined key word trigger any related software
development concerns?
No, the emphasis was just for the email, I wouldn't put that in the
actual commit log.
Would another look be needed on how the usage of the mentioned data
structure element was reduced over time?
No, it's fine, it's really just about the patch title :-) Thanks,


Vegard

Re: [PATCH] backlight-tosa: Delete owner assignment

From: Lee Jones <hidden>
Date: 2016-08-15 13:44:44

On Mon, 15 Aug 2016, Vegard Nossum wrote:
On 15 August 2016 at 13:12, SF Markus Elfring
[off-list ref] wrote:
quoted
From: Markus Elfring <redacted>
Date: Mon, 15 Aug 2016 13:03:29 +0200

The field "owner" is set by core. Thus delete an extra initialisation.
Hi,

Just a small nit on the patch title: "delete owner assignment" is
virtually useless as a title because it has no meaning without the
broader context and only describes the literal change. It's like
naming a patch "add a line" or "change the code"; it serves no
purpose.

How about "backlight-tosa: delete _unnecessary_ assignment"? This
immediately communicates the reason for/intent of the patch (there is
unnecessary code, thus we can simplify it).
  backlight-tosa: Do not manually assign THIS_MODULE to .owner

  This is unnecessary because ...
(Sorry about singling out this patch and the apparent bikeshedding,
this comment obviously applies to a lot of patches by a lot of
authors!)

Thanks,


Vegard
-- 
Lee Jones
Linaro STMicroelectronics Landing Team Lead
Linaro.org │ Open source software for ARM SoCs
Follow Linaro: Facebook | Twitter | Blog

[PATCH v2] backlight-tosa: Delete unnecessary assignment for the field "owner"

From: SF Markus Elfring <hidden>
Date: 2016-08-16 15:17:40

From: Markus Elfring <redacted>
Date: Tue, 16 Aug 2016 17:10:12 +0200

The field "owner" is set by the core.
Thus delete an unneeded initialisation.

Generated by: scripts/coccinelle/api/platform_no_drv_owner.cocci
Signed-off-by: Markus Elfring <redacted>
---

v2: The commit message was adjusted.

 drivers/video/backlight/tosa_bl.c | 1 -
 1 file changed, 1 deletion(-)
diff --git a/drivers/video/backlight/tosa_bl.c b/drivers/video/backlight/tosa_bl.c
index 83742d8..9706759 100644
--- a/drivers/video/backlight/tosa_bl.c
+++ b/drivers/video/backlight/tosa_bl.c
@@ -163,7 +163,6 @@ MODULE_DEVICE_TABLE(i2c, tosa_bl_id);
 static struct i2c_driver tosa_bl_driver = {
 	.driver = {
 		.name		= "tosa-bl",
-		.owner		= THIS_MODULE,
 		.pm		= &tosa_bl_pm_ops,
 	},
 	.probe		= tosa_bl_probe,
-- 
2.9.2

Re: [PATCH v2] backlight-tosa: Delete unnecessary assignment for the field "owner"

From: Lee Jones <hidden>
Date: 2016-08-17 09:48:21

On Tue, 16 Aug 2016, SF Markus Elfring wrote:
From: Markus Elfring <redacted>
Date: Tue, 16 Aug 2016 17:10:12 +0200

The field "owner" is set by the core.
Thus delete an unneeded initialisation.

Generated by: scripts/coccinelle/api/platform_no_drv_owner.cocci
Signed-off-by: Markus Elfring <redacted>
---

v2: The commit message was adjusted.

 drivers/video/backlight/tosa_bl.c | 1 -
 1 file changed, 1 deletion(-)
Applied, thanks.
quoted hunk
diff --git a/drivers/video/backlight/tosa_bl.c b/drivers/video/backlight/tosa_bl.c
index 83742d8..9706759 100644
--- a/drivers/video/backlight/tosa_bl.c
+++ b/drivers/video/backlight/tosa_bl.c
@@ -163,7 +163,6 @@ MODULE_DEVICE_TABLE(i2c, tosa_bl_id);
 static struct i2c_driver tosa_bl_driver = {
 	.driver = {
 		.name		= "tosa-bl",
-		.owner		= THIS_MODULE,
 		.pm		= &tosa_bl_pm_ops,
 	},
 	.probe		= tosa_bl_probe,
-- 
Lee Jones
Linaro STMicroelectronics Landing Team Lead
Linaro.org │ Open source software for ARM SoCs
Follow Linaro: Facebook | Twitter | Blog
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help