Thread (9 messages) 9 messages, 4 authors, 2015-06-01

Re: [PATCH v4 3/17] video: fbdev: gbefb: use arch_phys_wc_add() and devm_ioremap_wc()

flat view

From: Ingo Molnar <mingo@kernel.org>
Date: 2015-06-01 08:53:48
Also in: lkml

* Luis R. Rodriguez [off-list ref] wrote:
On Fri, May 29, 2015 at 08:41:44AM +0200, Ingo Molnar wrote:
quoted
* Luis R. Rodriguez [off-list ref] wrote:
quoted
+		gbe_mem = devm_ioremap_wc(&p_dev->dev, gbe_mem_phys,
+					  gbe_mem_size);
quoted
+		gbe_mem = dma_alloc_writecombine(NULL, gbe_mem_size,
+						 &gbe_dma_addr, GFP_KERNEL);
quoted
+	par->wc_cookie = arch_phys_wc_add(gbe_mem_phys, gbe_mem_size);
quoted
+	arch_phys_wc_del(par->wc_cookie);
quoted
+	arch_phys_wc_del(par->wc_cookie);
Could we _please_ rename dma_*_writecombine() to dma_*_wc(), so that the naming is 
coherent across the various APIs?
Sure, OK done. Will send once this series is merged and visible on linux-next. 
But who's tree should this go through? Since it depends on this series which 
goes through Tomi's tree should it go through there?
So we could do the rename near the end of the merge window, when all the patches 
have drained from maintainer trees into Linus's tree. Mind keeping it in your tree 
until then?

Thanks,

	Ingo
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help